Table Saw down?


I tried to use the Table Saw today in much the same way I have used it multiple times before. No joy. I appreciate that a requirement for the Table Saw is that you have to be smarter than the switch used to turn it on… I may be challenged in that regard.

Before you snigger too much…

  1. Yes, I plugged it in.
  2. I tried pushing the green “1” button. Multiple times.
  3. I also played with hitting/pulling the Emergency Stop in the event that was an issue (as some devices - like the Big Laser are persnickety if the Stop hasn’t been fully engaged).
  4. And, yes, I tried the green “1” button again. Multiple times.
  5. One time, it seemed like it wanted to start but didn’t.
  6. I confirmed (without the saw plugged in :slight_smile: that the blade spins freely.
  7. I found a digital multimeter and confirmed that the outlet is indeed providing juice (this is a skill I know I have).

So, if you have suggestions, or happen to have better luck when you try it, please let me know…


I used it earlier in the day, and it turned on fine, but it seemed like it hesitated when I got the stop button, and I had to hit it hard to get it to actually turn off. We may need to replace that start/stop switch unit.

I have seen a similar on/off switch on a bandsaw go erratic and then fail.

Upon unplugging and then un-screwing things to open the switch box and then getting into the switch body itself, there was a surprisingly large quantity of fine sawdust covering everything inside the sealed box and switch. A careful cleaning of everything and swabbing the actual copper contact piece parts with rubbing alcohol was followed with a successful reassembly and it restored reliable operation.

Apparently a ”sawdust air gap connector“ does not conduct electricity well. It can happen.


I’ll be in later this afternoon and I’ll take it apart for a quick look.