RE: [CHP] Android tethering Gingerbread 2.3.4 / $$$ for solution

I have the same issue. They must use some pretty serious packet inspection, which I have read is not legal, because even through an SSH tunnel they still detect the traffic… It wasn’t always like this… I tethered daily for about a year. Searching the web I have found no solution besides paying the asinine $30 a month tethering fee…

My phone is running Windows Mobile 6.5. I have run a version of ubuntu on my phone as well and it did not redirect me.

Found this

from what I had read at one time on ATT's tethering crackdown, the
system was easily able to tell due to one little piece... the TTL.

here's a quote and more info on it... probably pertains to verizon as
well.

For all you wondering how they can tell:

All IP packets have something called a TTL associated with them. It
stands for Time To Live. Every "hop" along the network from one router
to the next reduces the TTL by one. When it reaches 0, the packet is
dropped. This was introduced to keep routing problems from overloading
the network. If for example, by some error a packet was going around
in a circular path, the TTL would eventually reach 0 and prevent a
packet storm.

The thing is, ALL routing devices do this. OSes use standard TTLs. For
example, let's say both your iPhone and laptop use 127 for the TTL.
AT&T will receive packets from your iPhone with a TTL of 127, but
since the packets from your laptop pass through your iPhone first,
they arrive at AT&T with a TTL of 126. They can detect a tethered
device this way.

EDIT: Some people below have suggested changing the default TTL of
their tethered device (which is possible). I would just like to point
out that the max TTL allowed is 255, and if the iPhone uses 255 as its
default TTL, well there's no way you can set it to 256.

I'm not sure if our android tethering apps take this into account and
change the TTL of the traffic on the fly or not... would be
interesting to test out though...

Fumbling through some old links. I found this http://code.google.com/p/android-wifi-tether/
it requires root, and possibly, custom ROM. All of which should be
available for the nexus. Not after the bounty, but I have had a few
links lying around for such a case.

I would be interested too. I experienced this when I was tethering
with my G1, when my home internet connection was down and they
wouldn't send someone out for two days. It worked for a bit, but then
it shut out my internet connection with that same page. It would
display that page on my device for about half an hour and then it
would revert back to normal.

Call CBW and tell them you need an over the air reset. Then pull the battery on your phone and reboot. This has worked for me in the past on Froyo.

What exactly does an OTA reset do?

Alleviates my rage face and maybe also resets an arbitrary temporal quota. The latter is speculation.

I’m currently on a contract project @Bell

I remember in an off-shoot conversation with another employee that they are doing this to prevent ‘unauthorized’ tethering or something to that effect. It was a while ago so I’ve forgotten specifically what is happening/how one might circumvent it.

I’ll see what details I can turn up

The Tyler thing makes sense to me. Not sure a reset will fix this. You can use iptables on the phone to fix this but you need root access to do that. Although with the nexus this may just be by using adjustment (access phone as root) then making a change to init and/or proc.

Still traveling but might be able to experiment with this tomorrow.

Craig