polar 3d sd corrupt

Hi all,
SD card appears to be corrupt. Will not boot. Tried different rasp pi and still didn’t boot. Clay will respond with picture of error it brings up. Bill, is there a way to get a fresh os download?


Sorry to hear it’s not working. I saw something about obtaining a new SD card from the Polar support page. I hope a solution can be found soon. I’ve really been needing to use one of the printers.

or maybe Bill can send/bring in a copy and we can reflash the sd card.

:wink: Bill…calling Bill…

I’ll bring a new SD tomorrow night. Has anyone tried running fsck on it yet?


yes. Tim spent a few hours last night trying to get it to work, troubleshooting, etc.

The entire partition for / was unreadable /boot was readable, I managed to make a backup of the memory card before tinkering with it just in case.

When I mounted the backup imagine at home I found that the / partition was now readable (prior to running fsck), knowing this, I imagine that if I restore this image to a new 16GB card we will get further than previously.I plan to try this today.

As a side note the LED indicators are very deceiving as the blue polar was lit and the white 3d was lit, so most of our diagnostic time was trying to find the polar3d on the network in which it had not been connected to in some time.

If we need a 16GB SD card, I can donate one, (It is for a Pi right, so micro SD)?

I saw in the log, that over the spring, the on board Pi went bad. If that is the case this time also, I have one to donate as well if need be (if worst comes to worst, of course). Anything else I can do to possibly help?
I can come down anytime today (Monday), as it is my off day.

We had a NIB Pi that we moved the flash over to in an attempt to see if the Pi in the polar had gone bad. No love. At this point it’s a bad card, or the install is corrupted. As Tim pointed out - the polar3d lights come up in a state of “connected” prior to the Pi actually completing the boot process. Perhaps in Rev2 that can be changed :wink:


Thanks I already had another 16GB card, unless this polar 3d printer uses a common image available to download, which I did call support to see if they would allow that, I certainly wasn’t able to find it out on the interwebs.


Do you know where I can get the image that the polar 3d uses?
I believe online I read some articles that stated there was serializing done as well, not sure if this will have impact being that the hardware isn’t changing except the memory card.

Everybody, you can stop researching or trying to fix this. I will bring a new SD card Tomorrow! :slight_smile: FYI, there is no publicly available image do download.

As for the lights, if you watch my intro video (https://www.youtube.com/watch?v=S24xvDIJ6Ak), you will see what is happening… the lights initially show Blue over White (which is our logo) animation running at power on, then the 3D lights will turn off, indicating the Raspberry Pi is booting… then it will go through the boot up sequence of lights. If it ends back at the Blue over White, then the printer is fully communicating with the Polar Cloud. If not, it indicates it went to a different mode.

The current configuration is simply not booting, so it’s not running the script that controls them.


Maybe not everyone on the list knows your relationship with the polar3D printer Bill. :slight_smile:

Perhaps. :slight_smile:


Thank all of you for your help.

The Polar 3D printer is back online.


That’s wonderful! Thanks Bill!

Thank you!