LC05 Bluetooth Modules

Does anyone have any experience with the LC05 module that’s made by LC-tech?

I’ve got a few and I can’t seem to get them into paring mode. I’m sending:


at 9600 baud (and at 3.3v), however, the module itself doesn’t return anything back to me. I’ve verified that it’s not an idiot running the breadboard by hooking my logic analyzer up to it and it’s not sending me anything back.

I’m about ready to run and grab a USB bluetooth module from Micro Center and just use a R.pi to do this other than arduino, but, I’d rather low-level it just so that I can get it done.

I’m open to ideas…


I have some extra 5V compat modules.
In my experience, 95% of the time issues with bluetooth modules boil down to baudrate and/or signal level issues.
I’ll bring you one of the modules I have to play with if you like. I also have a few USB->TTL bridges for test/debug purposes.



If you let me know where you get your modules, I’ll order a few for the next time I’m dealing with this.


I’ll be down tomorrow. I’ll bring you a module then.

I have a couple of these too. Even if your manual states default baud rate is 9600, try 38400. The module will only accept AT commands when it is NOT paired (meaning don’t connect anything to it.) The KEY pin on the module should be doing a hi/lo flash. You can also force the STATE pin low (I THINK, maybe high?) and force it into AT command mode.

Don’t worry about getting it to pair until you get an “OK” to “AT”. To take the arduino out of the loop, you might use an FTDI breakout.

my 0.02.

Interestingly enough, I pulled mine out of my shoebox again today after fighting with trying to do the same thing using python’s PyBluez modules, [but gave up after I realized that not only did the documentation suck, but my bluetooth modules couldn’t get into the right modes for me to discover it correctly].

the LC-05 will respond “OK” the first time I run my program, but, after that, it won’t respond to anything that I send it.

I’ve got a line on my analyzer looking at the “KEY” pin, but, it’s not seeing the high/low flash, and I know I have not paired anything to this module yet.

The “STATE” pin (PIN 11 on the module, not the breakout board) needs to be HIGH, for future reference.

I can now get it to respond “OK” to “AT”, however, once I send it the AT+INIT command, it never returns “OK” – I still get the 2Hz blink on the LED and no other commands that I send it elicit a response.

I’m going to probably pack up and head over to the hive for some more troubleshooting.