Gigabot woes

Gigabot suddenly thinks its bed is 2X larger than it is.

I printed something sliced with Simplify3D set on standard preset for a standard re-3D gigabot. I noticed, after I stopped the machine, that Simplify had written at G-code start:

M92 X118.52 ; calibrate X

M92 Y118.52 ; calibrate Y

M92 Z4031.5 ; calibrate Z

M92 E1710 ; calibrate E

So, the steps per unit is set too high… What should it be for our GigaBot?

I really didn’t think the simplify 3D default gigabot profile would re-calibrate the steppers like this. Sorry. My previous print, sliced with Cura worked perfectly.

Also, no disastrous crash or anything. Just out of cal.


I believe that the Marlin version most recently uploaded by Bill is the one labeled “Hive13_3_52”…according to the config.h file, the calibration should be:

DEFAULT_AXIS_STEPS_PER_UNIT {59.251,59.251,4031.5,1850}

which would explain why gigabot thinks its even bigger (giga-er?) than usual.

Alternatively, you could try M502, M500 to reset eeprom


Already ahead of you.

I sent M92 X59.251 Y59.251

X&Y are right now.

Printing Calibration cube now.
X and Y are fine, extrusion looks good.
1st layer Z is off (sensor). I’m adjusting now. Mike, you may need to futher tune this, I’m eyeballing it.

And, yes, I hit M500 to save the corrected values.


All good, I fixed it.

A calibration cube came out perfectly. 20mm on all sides.

Note, the Z probe was loose, and it did get knocked out a bit. I adjusted, but it may need additional fine tuning. AKA, don’t try super thin 1st layers till you’re sure… Normal printing should be fine & dandy (1st layer > 0.2mm)

On a another note:

MIKE & BILL: do we have a copy of the Marlin firmware currently loaded? If not, can someone link me the source and so I can back it up to the server? I’d hate to loose all the progress there.


Final note,

IF you try the default gigabot configuration built into simplify3D, adjust the start script, making sure to GET RID OF ANY M92 G-Codes.


The Marlin source code is out there on Fastor. (It was also on the laser machine… but just as another backup.)

Sorry, I don’t have the link off the top of my head.


Also note, it’s not stock. There were several other changes to make it work with the autolevel probe.

Found it. I’ll make another backup, as Ian has been overhauling the computers a lot lately.

Your modifications work great. I will make some scripts and presets so that software profiles match the machine more closely.

Is it possible to do the bed tramming with 3 points rather than 9, or is it doing more than simply tramming with your additional code?

Also, is there a G-Code command to change the Z offeset for the probe? ie. on a PrintrBot it’s M212 Z[xxx]. Might some in handy when the sensor gets loose or if it takes a knock.

Thanks again, Bill.


My suggestion is we live with the 9 points… there is a bug in the 3 point code and it was a lot easier to use the 9 point instead of fixing it.

Also, since it’s based on Marlin, the M212 code should still be present. Just do an M501 and see if it reports it… if it does, then it supports it. In fact, we might actually be already using it.


M212 does not show up on M501

I tried
M212 Z1

Then tested. No change. It printed at the same height.

Is there an area of firmware where this needs to be enabled.

Is M206 in there? If so, that’s it.