Donated Polar 3D "Pixie" Printer

I left one of our prototype Polar 3D Printers… Serial # ONE THREE in the FabLab. I will be setting it up tonight on the Laser computer.

It uses 1.75mm PLA Filament only right now and I will be using our Polar 3D Desktop software to make things easy. Later, once everyone get’s comfortable with it, we can move to Repetier-Host and other materials. It can use NinjaFlex as well as standard ABS… along with all the other exotic or not so exotic materials.

The Hive doesn’t have much 1.75 filament in stock at the moment, but we should order some. (I tuned our software to work with our specific filament, but it is certainly not required… it’s just that I know a guy… you know what I mean?)

If someone want’s to order some from us, please feel free to use our website ( and I can bring it with me to the hive. We have thousands of rolls in stock. (We actually have 1kg and 1/4kg rolls in 11 different colors.)


This is great Bill, thanks for bringing it in!! Looking forward to checking out the Polar 3D software.

I have a roll of 1.75mm white PLA for the ultrabot which we can use. I agree we should order more though. Nice to see that the Polar3D website is not doing a crazy price markup on filament like Makerbot…



I have been looking to buy a 3D printer for use at home. Do you think this printer will be up and running for the Tuesday night meeting? I’d love to stop by and see a demo. A little disappointed there is no Linux version of the software, but I guess I could setup a Mac for it.


Yay, that means I can finally buy one right? Now to sell the wife on it…

Actually, Mike, we ARE doing a crazy price markup!!! :slight_smile: Just not THAT crazy!


Yep, it will be printing.


Yes, Marcus, you can buy one now. is the one stop shop to place your order. :slight_smile:


The Polar 3D printer is all set up. It is configured for the Polar 3D Desktop Host only right now on the Laser’s computer.



Awesome! Will someone be around the meeting tonight that can give a quick demo? Just wanted to see it in action - seriously considering getting one.


Just wanted to share my experience here…

A) Doesn’t look like Polar Host likes the Fastor Server - Coppied my small part to the desktop

B) When I loaded my model it was upside down, I ended up reorienting the .STL in rhino3D (feature request: move/rotate)


D) All printing attempts but 2 (out of ~8) the Z auto-calibrate failed with a rapid tick/knocking sound. (jamming?)
– Found no physical interference, print proceeded off plate - in air.

E) The Software kept crashing or becoming unresponsive. I became restarting the computer for every new attempt. (gave up, no prints)

I’m not sure what you mean by A. Fastor is a file server… why run the desktop software on it??? (If Fastor is Ian’s Windows 8 box, then we are aware of it… it won’t reboot in safe driver mode without pulling a bunch of hardware out of it… nothing to do with the software.)

And as for B, you’re obviously not using the latest software. It has a rotate object feature built in to it.

C, Home Depot, KMart and Lowe’s all sell it… go get you some! :slight_smile: But I don’t recommend blue painters tape… I recommend Aquanet hairspray in the purple can… $2 at Meijer… produces much nicer quality prints and costs a lot less than the tape.

D. The home is failing on that older machine due to an old bug in the firmware… you simply need to reset it between prints. That’s a bug I will fix in the firmware when I get a chance… the new machines use a different mechanism that isn’t effected by that issue.

E. What computer are you doing this on… I’ve been printing just fine on the laser computer… is it possible it’s due to incorrect software install? When is it becoming unresponsive? During slicing? If so, run Slic3r manually and see what it is reporting… Slic3r just started adding a popup that is not visible from within the host app (Now called Desktop) and the user is unaware of it so they can’t dismiss it. Running Slic3r.exe manually let’s you see it to dismiss it.

I printed several objects just Friday without issue and I know Mike was printing some things as well.


Yep, I’ve had successful printing with the the Polar3D hooked up to the Laser cutter computer. I printed from Repetier host using the polar3D slic3r settings and polar converter. Just used hairspray, no blue tape.

I’ve also experienced the issues with homing, hopefully Bill can get the firmware updated but until then resetting the printer should work…

Both repetier and polar3d host software crash for me when trying to slice or load gcode from very high poly-count models. I get an out-of-memory crash popup. I think this is a combination of the larger gcode file size generated with the polar converter, and the low memory of our geriatric laser cutter computer. The same files do not crash repetier on my laptop. Too bad Ian’s more powerful windows 8 box is not cooperating…

I also tried printing from SD, but did the printer did not seem to recognize the SD card. Bill, any advice for SD printing?


The fastor issue is one you have seen before Bill. It is caused by slic3r not being happy with file paths from a file server.

I will look into the SD card issue… was it with Polar 3D Host or Repetier? I seem to remember printing with it, which is the solution for out of memory issues. The file can’t load into memory after slicing, so you can copy it to an SD card.

If all else fails, simply copy the gcode file to the SD card and rename it “auto0.g” and when the printer powers on, it will automatically load and print that file.


What is being put on fastor? Config files and working files should be local.


A) Yes, I tried to migrate my .STL and open it in Polar 3D, as Jon mentioned it’s a slic3r issue.

B) I DIY! I’ve upgraded the laser computer from 0.2.4 to 0.3.3…
B1) Auto-home? Heater control? Some basic controls might make things easier for user with prior 3D printing experience.
B2) Auto-center? My object came in off center, I think something else is going on as it was printing ellipses instead of circles… but it was printing right on the edge of the plate.

C) I brought a small amount in… it’s from DAAP :wink:
C1) The first layer was running much too fast, even on “slow” quality, kept knocking off on the first layer.

D) So far okay tonight on the Z honing… when I retried my print it wasn’t honing the lateral coordinate correctly though, led to some stepper binding.

E) Running more smoothly, but still get “exception raised” after if software is restarted after fresh load (on fresh boot).

F) Between ellipses and speedy initial layers I am going to try get something out of Repetier!

Thanks for the tips all!

More Home Issues!

G) X-axis home? I was working with round or cylindrical shape.Objects came out as a tear drop shape, I trialed some printer settings (min, max, 0) none of these seemed to give consistent home results. Sometimes it would “home” and just push out X+ in 2x ~20mm steps, lastly I thought I had it homed, it “parked” correctly but when it went to print it maxed out -X and proceeded to print a tear-drop skirt.

  • I’m giving up for now, hopefully someone can check the defaults on the laser computer.
  • I’ll leave my tear drop shaped print near the printer!

Still curious of the potential for this once it is running smoothly!

It sounds to me like you're not running the Polar3DConverter in your post processing in slic3r. That's needed in order to get the coordinate mapping.

Also, this software isn't designed for someone with even a little experience. If you need those controls, use Repetier... our software is designed for our PLA and doesn't need any additional adjustment temperature wise. As for Auto Home, I'm not sure what you mean... when you start a job, it homes twice and automatically positions the head in the center.

That machine at the Hive isn't a production unit and doesn't have the production firmware... so sometimes it is not homing. Again, it will home correctly if you unplug the printer and repower it. But, if you attempt a new print job, you will need to recycle it to get it back to normal.

If you use "Open With" with our software, it will throw an exception, but if you click continue, it will work fine. It's a known issue. If you open the host software and then load the part, you won't get that error.



Am I correct in assuming that when something is being printed that the laser is unavailable? Or is it like the laser, that once you send the job the computer is no longer tied up?

You can use both at the same time without issue.