CNC Router Problems

Hey everyone,

Tim was helping me out with a project last night on the CNC Router when we were met with “Limit Switch Triggered” mid-cut as shown in the picture. Tried resetting, restarting, and re-zeroing, but the error kept occurring either immediately or about 10-15 seconds after the spindle started up. I didn’t notice anything weird with the LEDs, but I also don’t understand the ins-and-outs of the machine so I just took a picture for reference.

I believe Coy ran into the same problem last week, but if I remember correctly the problem fixed itself.



CNC Router Error1.jpg

CNC Router Error2.jpg

I ran into an issue with the computer side Y limit switch not being seen (even if it was “tripped”).
I ended up chasing down the wiring to the small input board. I just removed and then reattached the wires into the terminal and it started working.
I wonder if this is a ghost of that problem.
Could you tell what limit switch was tripping?

I’ll be down there before the meeting tonight, maybe we can try and replicate the problem.

I couldn’t tell just by looking at it, but that’s not to say that I was missing something. I’ll be heading down soon so hopefully we can figure it out here in a few.



You should be able to see the pin that is triggering the fault in Mach3. Then troubleshoot from there.