Big laser update

The big laser is still not available yet. It is working great, BUT, it is not reliable enough to create consistent cuts or engraves in various materials. Acceleration, diffusion, corner acceleration, corner power, arc and circle behaviors, etc are being dialed in.

So, do not use the laser right now.

I’m continually working on it, and expect to reopen it next weekend.

New documentation, signage, rules, etc will need to be posted too.

Anyone want to help out? It’s pretty cool, and would go faster… Just reply. If you do, we can beta test with your project files…


A note on acceleration. The laser does a little stutter step when approaching circles where it stops for a fraction then restarts at a lower speed. This is wearing the set screws on the Pulleys. I might be able to help wed or Friday if you can send some guidance.

Yes, I know. 99% sure this is due to the motion settings being weird. Turns out that LaserCut has completely independent settings for acceleration in arcs and circles, and that they were completely un-configured. From my limited work with open source laser and 3d printer firmware, this most likely means that when it transitions from a line into cut a circle cut, the machine sees an instruction to stop and restart instantaneously, without acceleration or deceleration. Sound about right?

LaserCut is cryptic, with lots of settings called things like “diffusion” and “space”. I’m going through everything while cross referencing the manual and doing careful test cuts. I’m taking notes so I can document it on the wiki later.

If I’m in on Wed or Friday I’ll let you know. I’d appreciate the help.


Almost. It’s certainly stopping and restarting immediately, but it happens about .25” or so from the start of a circle. It acts like an improperly implemented pseudo acceleration.

Yes, since the acceleration was not even entered for circles, it’s using the “start” aka jerk accell to to do those moves. The movement planner interval (which is poorly translated to “diffusion”) was set on 0.007, as well, whereas 0.1 is a typical recommended setting. So, my guess, based on documentation, was that it was breaking those moves up into 150 separate sub-movements, rather than just 10 – stuttering.

We’ll get there…

I can always come up with projects for you to beta-test. (:

I have existing ones (already set up in EasyCut Pro) we can re-adjust for the newer, more powerful laser.


Just a reminder:

The lasers are off limits, even though we are very close to making them available. THE KEYS WILL NOT / SHOULD NOT BE LEFT IN EITHER MACHINE, to protect anyone who is simply not aware of this and tries to use them. At any given point, the laser, fans, pumps, or chiller may be in unsafe condition. Using the laser now could easily result in a fire, a blinding flash to retinas, flesh torn off of hands, or decapitation.

Thank You for your patience. Myself, Brett, Dave V, and others are working hard (and a lot) to move forward with this and get them working for everyone.

Please direct any complaints into a deep and lifeless black void.



The new fab-lab sheriff in town

I spent this morning working the z-axis issue. I think our stepper controller is bad. It’s acting as though one step is intermittent and it can only move if it’s able to coast through the dead step. Here’s what I did:
- tightened all the set screws
- tightened the belts
- verified each of the screws turns freely
- lessened the pillow block screws to ensure it wasn’t binding due to misalignment
- swapped motors side to side to check for a bad motor.

The controller is a Power Step 2M982. I dropped amperage from 7.8 to 7.0 and the table wouldn’t move at all, indicating that we need the full capacity of the controller. The controller is only rated to 7.8 amps for intermittent use, which should be fine but indicates it might be worn out. They’re about $50 on eBay, I couldn’t find them new. Note this could also be an intermittent short in wiring, which I was not able to check.

Thanks Brett,

We should check for shorts. That behavior is more common with worn out connectors and wires. Since the problem seemed to happen more at low Z heights, maybe the table is tugging on something when it passes the wire loom (which is very close to the gap)…

When stepper drivers go bad they usually fail catastrophically, but who knows. I’ll add the possibility of replacing that driver to the “contingency” budget.


Easiest first test for short would be:

With machine off – set a VOM to ohms and measure across the coils at the motor and at the output of the driver. The resistance should be the same for both coils (or coils and taps if unipolar). There should not be an open circuit nor a short. Sometimes an additional test in diode mode across the coil output pins of the driver can also give some insight, depending on how the H-bridge is wired.


The z-axis doesn’t work anywhere now, high or low. The trouble is there’s no connectors except the screw terminals at the controller. I did not think to check coil resistance .

I’ll take a look in the next couple days. Even if a FET is blown in the controller, it should be repairable with a few parts and the rework station.


I checked the connections, motor, and driver today. The driver is probably blown. Most likely a splice failed on one coil of left motor. We’ll need to pull that driver and take a look inside to know more. Steppers are good.

I can rewire sometime this week. Can we order a new controller? I’m suspicious of the remaining drivers in the existing controller, and considering we’re running continuously at the max current it might be good it keep a spare.

TL;DR Don’t put sh*t inside the laser where the belts are – EVER!! Read on to know & learn…

I agree. The high current was probably also due to the fact that the 2 motors are wired in parallel to the driver. Thus, the driver was being overworked with an improper load.

I will get a driver. I will also offer some learning and choices here:

What happened – Lorin’s most likely scenario (not guaranteed to be accurate, but likely):

  1. Motors were twisted, soldered, and heat shrink spliced to the controller wires. That’s fine, but soldered splices become faulty if mechanically stressed - solder is brittle.

  2. People were putting heavy sh*t, like the rotary attachment, on top of these splices (underneath the table). Doing this broke a single splice.

  3. Now, with 2 motors = 8 coils (each coil is R=0.9 ohms and L=3mH and V=2.7V when juiced). The load seen by the driver should be A coils=0.45 ohms B coils=0.45 ohms. I saw A coils = 0.45 B coils = the ohm meter showed the resistance increasing slowly from 0.1 to about 0.7 (which means there’s capacitance and or inductance messing with it). When energized with continuous current, I measured, A coil = 2.7V B coil = 28mV.

The 28mV means that the driver simply wasn’t energizing the B coil. Blown driver. The R reading shows that B coil was still loaded, but with 0.7 ohms and an additional inductor connected only on one side, which reads like a capacitor on the meter. Since there was a load >0, no blue smoke, no immediate failure. Rather, we would have seen a sort of jitter as motor 1 has to do all the pushing and force motor 2 to turn during 1/2 of the phase. The problem is that pushing motor 1 harder 1/2 the time not only creates strain, but also creates back EMF in the open coil on motor 2. The back EMF from 2-3 mH and 48V could produce back pressure of 1kV+. The driver doesn’t really “See” 1kV+ coming back full force, as motor 1 is still in circuit, however, just like physical pressure, it makes motor 1 a lot harder to turn and time. Plus, the H-bridge mosfets still get hit with a high voltage spike every step, which is most likely dissipated by the flyback diode that protects the FET (usually built into most FETs these days). We get skipped steps as speed increases, and eventually the driver blue-smokes itself because the diode can only take a limited amount of back EMF over its life…

Now, the options. Would you prefer to splice the motor wires with solder & shrink this time or to crimp connectors onto the wires (inline molex of JST 3A connectors)?

Do we want to replace with the same driver or a different driver?

If we didn’t have all the weirdness, I doubt that the driver was being overworked too hard. The max current would be 6 Amps and the driver is rated 7.8 amps. However, it was working way harder than it should have due to this open coil.

See, impedance is fun!


Here’s a brand new replacement that is compatible for $47.50. Newer model.

The 2M982 is an old model. The used units I see on ebay look like they’re all coming from china, too.

What do y’all think? LMK. I appreciate other eyes checking the cross-checking the specs with the old 2M982 driver before I order.


Sorry, this one for $47.50:

Regardless, both sellers have stock in the USA.



Lorin -

In my last passing conversation with Brett, I thought he mentioned that this driver was already on order. Do you know if this the case? I realize you're out of town for a bit, so if I can assist by placing the order, I'm happy to do so. I just don't want to double up.

- Ry

There we’re a couple issues getting it, but it arrived yesterday. I’ll me matching the switch settings today and installing on Sunday.