Big CNC Spindle Behavior

I meant to make a thread on this forever ago, but was just reminded by John in the Gigabot thread.

I said:

“…on the big CNC we have to manually start the spindle before cutting since we do not have automatic spindle control set up.”

John said:

“The CNC has had its settings updated for over a year, and spins up automatically now.”

To branch this convo off here:

Are we sure it’s working properly? I recently helped someone with some CNC work and they were trying to run a program with spindle control and it kept crashing because there wasn’t enough delay to allow the spindle to get up to speed before it started trying to cut. It just plowed the endmill into the material with the speed still down at 3000-4000 RPM instead of the commanded 18k. Perhaps the solution is setting more aggressive accelerations in the VFD?

Slightly different problem, but related: currently the CNC spindle begins spinning at a low speed on machine power up. you have to press stop on the VFD to get it to stop spinning. this seems an unsafe bootup behavior to me.

Not doing this during class in Feb.

Wrong Profile in use? Something got edited? Hardware problem?


Weird. I think we found a setting in Mach III that is spindle delay. I seem to remember it being in the I/O page.

I wonder if it has been modified.

The spindle spinning when it's not supposed to be is something that started with the rebuild/rewire work. Beyond that, I have no idea what is going on.

As far as Mach3 settings are concerned

To set “Dwell while spindle comes up to speed”,



Ports and Pins

Spindle Setup

General Parameters (a panel in the Spindle Setup window**)**

four “Delay” settings (CW & CCW, spin up and spin down (delay in seconds) (total of four options))

A good number is 20.

I don’t recall if this is saved into a Profile when Mach3 is quit, but the most recently dated Profile (in Feb) was associated with the correct machine spin up before the spindle

would move to cut a tool path.

That would be where to check Mach3 for the setting, anyway!


Or you could press the dwell button.
Or select the gcode text then click run from here, then you get a pop up screen that will allow you to check a box allowing the spindle to get up to speed before you click the start button.

It worked for me last week.